Investigating some reports of slow performance

Incident Report for TestRail Cloud

Resolved

Our DevOps team quickly identified the culprit behind performance degradation and was able to resolve the issue quickly.
Posted Aug 02, 2021 - 13:30 UTC