Degraded Performance
Incident Report for TestRail Cloud
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 20:02 UTC
Update
We're pleased to report significant performance improvements across our platform, with decreased error rates and API rate limits restored to their normal levels. Our team continues to closely monitor the system to ensure ongoing stability and reliability. Thank you for your patience and support.
Posted Feb 27, 2024 - 15:50 UTC
Update
Some customers are experiencing degraded performance. Our engineers are investigating.
Posted Feb 27, 2024 - 09:02 UTC
Monitoring
The incident has been resolved, and all customers should now have access to their instances. Please note that we have temporarily increased the API rate limit restrictions, and reduced the background task frequency while we monitor the system. We appreciate your patience during this time, and are committed to maintaining service stability.
Posted Feb 27, 2024 - 00:10 UTC
Update
Some customers may experience maintenance windows longer than 15 minutes as our team continues to work to resolve the incident.
Posted Feb 26, 2024 - 20:19 UTC
Identified
Our team is actively working to resolve the incident. Customers may see their instances in maintenance mode intermittently, but for no longer than 15 minutes.
Posted Feb 26, 2024 - 18:57 UTC
Investigating
Some customers may be experiencing degraded performance. Our engineers are investigating.
Posted Feb 26, 2024 - 16:22 UTC
This incident affected: TestRail Cloud.