Slow performance
Incident Report for TestRail Cloud
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 12:15 UTC
Monitoring
We have identified the cause of the instability and implemented a fix which we are currently monitoring.
Posted Jun 14, 2022 - 14:19 UTC
Investigating
Some customers are experiencing slower than expected TestRail performance. We are currently investigating this issue.
Posted Jun 14, 2022 - 12:58 UTC
This incident affected: TestRail Cloud.