Degraded Performance
Incident Report for TestRail Cloud
Resolved
This incident has been resolved.
Posted Feb 19, 2024 - 13:44 UTC
Identified
Our engineers have identified the potential source and implemented a fix.
Posted Feb 19, 2024 - 12:34 UTC
Investigating
Some customers may be experiencing degraded performance. Our engineers are investigating.
Posted Feb 19, 2024 - 10:48 UTC
This incident affected: TestRail Cloud.