Some TestRail instances are currently in maintenance mode

Incident Report for TestRail Cloud

Resolved

All systems are operational.
Posted Jun 01, 2023 - 11:43 UTC

Monitoring

The database has been recovered and all affected TestRail cloud instances should now be back online. We are continuing to monitor the database for any further issues.
Posted Jun 01, 2023 - 09:30 UTC

Identified

The cause of the database issue has been identified and our engineers are working to solve the problem. In the meantime, we are also building a new database from a backup with a view towards switching affected customers to the new database.
Posted Jun 01, 2023 - 08:28 UTC

Investigating

One of our databases is not responding correctly and as a result, TestRail instances reliant on it are currently in maintenance mode. Our DevOps team is investigating the problem.
Posted Jun 01, 2023 - 07:35 UTC
This incident affected: TestRail Cloud.