TestRail CSS & JS assets are loading slowly or not at all for some instances
Incident Report for TestRail Cloud
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 09:19 UTC
Investigating
We are currently investigating this issue.
Posted Oct 21, 2021 - 09:13 UTC
This incident affected: TestRail Cloud.