Gateway errors when accessing TestRail
Incident Report for TestRail Cloud
Resolved
This incident has been resolved.
Posted Mar 01, 2022 - 20:10 UTC
Monitoring
We've identified the cause of the gateway errors and implemented a fix. Service to TestRail Cloud has been fully restored and all instances are showing as online and operational. We will continue to monitor closely to ensure there are no other issues.

If you are still receiving any 502 or 504 gateway errors, please email us at contact@gurock.com so that we can take a closer look at your specific instance.
Posted Mar 01, 2022 - 20:09 UTC
Update
TestRail Cloud continues to experience issues with 502 or 504 gateway errors. We know this is frustrating and we’re working to resolve this as soon as possible. We have escalated this to our engineering team, and will provide an update as soon as more information becomes available.
Posted Mar 01, 2022 - 18:35 UTC
Update
We are continuing to investigate this issue.
Posted Mar 01, 2022 - 13:39 UTC
Update
We are continuing to investigate this issue. We do not have an ETA for resolution at the present time, but expect to provide one shortly.
Posted Mar 01, 2022 - 11:23 UTC
Investigating
Some customers are experiencing gateway errors, e.g. '502 Bad Gateway' or '504 Gateway Time-out', when attempting to access their TestRail cloud instance.

We are currently investigating this issue and will provide further updates shortly.
Posted Mar 01, 2022 - 09:11 UTC
This incident affected: TestRail Cloud.