Degraded Performance for Some Customers
Incident Report for TestRail Cloud
Resolved
We successfully resolved the issue, and normal service has been restored.
Posted Feb 18, 2024 - 23:48 UTC
Update
We're continuing to monitor for any further issues while the team is working to a full resolution.
Posted Feb 16, 2024 - 15:53 UTC
Monitoring
We identified degraded performance that may affect some customers in connection with the 14-Feb partial outage. Our team is actively investigating to ensure a complete resolution.
Posted Feb 15, 2024 - 15:32 UTC
This incident affected: TestRail Cloud.