Degraded Cloud Attachments Service
Incident Report for TestRail Cloud
Resolved
Our DevOps team has applied a fix for this issue and after a period of monitoring, has determined that users should no longer be experiencing issues related to the TestRail attachments service.

We appreciate your patience while we dealt with this matter.

If you're still experiencing errors that result in a "Call to a member function prepare()" message, please reach out to our support team and we'll be happy to assist.
Posted Oct 16, 2023 - 21:24 UTC
Monitoring
Our team is stabilising our hosted infrastructure after applying the necessary fixes. We are continuing to monitor the situation closely.
Posted Oct 16, 2023 - 07:08 UTC
Update
We are continuing to work on a fix for this issue which is affecting a small number of customers. Thanks for your patience. Our team is working hard to complete this activity as quickly as possible and we appreciate your bearing with us while we do so.
Posted Oct 14, 2023 - 08:45 UTC
Update
We're still working to fix this issue as fast as we can. Thanks for your patience while we do so. We'll share updates as progress is made.
Posted Oct 13, 2023 - 08:24 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 12, 2023 - 17:20 UTC
Investigating
The TestRail Cloud Attachments service is currently experiencing performance issues affecting a subset of attachments functionality for a small number of TestRail Cloud users. Our DevOps team is deploying a fix and we expect to resolve this matter promptly.
Posted Oct 12, 2023 - 17:20 UTC
This incident affected: TestRail Cloud.